Announcement

Collapse
No announcement yet.

Bad stutter under throttle

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad stutter under throttle

    Hey everyone, itís been a LOOONG time since Iíve been on here! I have a basically stock 98.5 SVT and it is not running well at all. If Iím light on the throttle like really light on it, it will accelerate ok but otherwise itís BAD. I have had a couple of misfire codes. I replaced plugs, wires, ignition coil and fuel filter. Iíve actually done the plugs and wires twice just for kicks... itís been like this for a couple of months. Any thoughts?

    If I hammer the throttle and let it struggle Iíll get a CEL that says cylinder 6 misfire, plug looks good and wire seems good. Is it possible I got a bad ignition coil? Itís an accel brand one I believe. The car has 200k on her but was running great until this. Now itís my sons car so I havenít been super eager to get it running SUPER great... it keeps him going a little slower! ;-)
    1998.5 E1 SVT Silver frost #5850
    1999 SVT Black - Dead, RIP

  • #2
    Could be injectors too.

    Comment


    • #3
      ...... Inlet Manifold Runner Control working properly ? Stuck open ? ....G.
      ST24. LPG, 2001 ST200 motor, 65mm P&P'd TB, 80mm MAF, headers, lowered, sway bars and strut braces, 300/278mm brakes, 3.51 FD 3.0L tranny, Torsen, Fidanza.... Vortech nearly completed.

      WANTED; Custom gauge guru for ST200 overlay job... pm me..

      Comment


      • #4
        Switch to stock coil, they are far more reliable anyway.
        Don Higgins
        Crew Chief Pro Drag Racing Software
        http://www.crewchiefpro.com
        1999 3.0 Turbo CSVT ** 2013 American Dragster with 1100 Horsepower 7.28 @ 185 mph

        Comment


        • #5
          Also check the herd of electrical connectors on the rear valve cover, passenger side. Electrical connection problems here can cause misfire issues, as the coil trigger wires go through one of these connectors. These connectors also handle cam and crank sensor signals back to the PCM, and crank sensor signal problems can manifest as ignition issues.

          Agree with Don, some of the aftermarket coil pack choices for these engines are... sub-optimal.
          I collect Ford's Red-headed step children.
          1985 SVO Mustang (turbocharged track rat)
          1989 Taurus SHO (supercharged track rat)
          1999 SVT Contour (Sedanus-Grocerygetter-Rapidus)
          2008 Mercury Milan Premier (Comfy boat)

          Comment


          • #6
            You cannot see shorting down the side of an otherwise normal looking plug or the internal resistance of a plug wire AT ALL. Meaning a visual check can be worthless there.

            And I wouldn't give $5 for an Accel coil at all. HIGHLY overrated. These are not the days of Accel in the '60s and '70s................

            Comment


            • #7
              Thanks for the tips! I have REPLACED the plugs (all of them) and wires twice so Iím thinking those should be good... checked the IMRC and itís all good, opens and closes depending on rpm.

              The stutter also causes a backfire if I keep the pedal down.

              Connectors and wires all look good. Would seafoam through the UIM Help potentially clean the injectors? Or do I need to tear it down and take them out?
              1998.5 E1 SVT Silver frost #5850
              1999 SVT Black - Dead, RIP

              Comment


              • #8
                Seafoam thru the fuel tank is probably a good way to go, for injector cleaning. It may take a while to work its magic.

                There is no substitute for removing the UIM to clean it.... you really are only cleaning the cylinders putting seafoam thru the TB.

                .if the misfire is still localized to no.6 cylinder then .... could be a cam follower that is blocked / dirty inside, causing it to operate erratically.

                Does the oil get changed regularly, are the cam covers clean inside ? is there lots of oil inside the rubber bellows on the TB where the front breather pipe connects ? ...G.
                ST24. LPG, 2001 ST200 motor, 65mm P&P'd TB, 80mm MAF, headers, lowered, sway bars and strut braces, 300/278mm brakes, 3.51 FD 3.0L tranny, Torsen, Fidanza.... Vortech nearly completed.

                WANTED; Custom gauge guru for ST200 overlay job... pm me..

                Comment


                • #9
                  I do oil changes every 7k with Mobil 1 synthetic. The rubber bellows are pretty clean. Iíll try some seafoam in the tank for a few tanks and see how it goes. If that doesnít help Iíll do more of a tear down and clean the injectors.
                  1998.5 E1 SVT Silver frost #5850
                  1999 SVT Black - Dead, RIP

                  Comment


                  • #10
                    .... interested in the injector cleaning procedure.

                    This has come up a few times but I've never seen it done ... ie removing / replacing the filters.

                    Seen a flow bench for metering, matching and balancing sets.... stuff like this is always good to know ...G.
                    ST24. LPG, 2001 ST200 motor, 65mm P&P'd TB, 80mm MAF, headers, lowered, sway bars and strut braces, 300/278mm brakes, 3.51 FD 3.0L tranny, Torsen, Fidanza.... Vortech nearly completed.

                    WANTED; Custom gauge guru for ST200 overlay job... pm me..

                    Comment

                    Working...
                    X