Announcement

Announcement Module
Collapse
No announcement yet.

Code P0240: Catalyst System Efficiency

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Code P0240: Catalyst System Efficiency

    Hey everyone, I did a search and there was another thread on this topic, but the OP didn't have the proper info to diagnose the problem, so I am asking it again. Hope someone can help.

    Someone said in the other thread that this code often comes up without there being an actual problem, but I want to make sure since it is the ONLY code that comes up. It came up maybe a thousand miles ago while in Fort Lauderdale and we wiped it. The CEL came on today, DAP scanned it and found "P0240: Catalyst System Efficiency Below Threshold (Bank 1)"

    I doubt my cat is bad, but the parts monkey who scanned it said it was a vague error and that it could also be a vacuum leak. Whats up?

    Thanks!
    1998.0 Mercury Mystique 2.5L || De-knauberized ||.................................................. . CHECK
    The token, non-licensed non-DUI member................................................... .....................ENGINE

  • #2
    This code is at times related to a bad cat. The first item on the trouble shooting list is the Engine Coolant Temp sensor. This tell the computer the temp of the engine and adjusts the fuel to match the temp. If this sensor is reading low then you get more fuel than need. Part of that fuel is not burnt completely and then will trigger a cat code. Fairly cheap and easy fix. This is not the sending unit for the temp gauge in the dash. I would still look at the other items on the trouble shooting list. Making sure the wiring to the O2 sensor is not damaged is a fairly easy check. I had a mechanic do a clutch job and they had wrapped the sensor wire around the EGR tube. Burnt the insulation off the wires in short time. They did install a new sensor at no charge.

    P0420 - Catalyst System Efficiency Below Threshold (Bank 1) Indicates Bank 1 catalyst system efficiency is below the acceptable threshold.
    Malfunctioning ECT/CHT
    High fuel pressure
    Damaged exhaust manifold
    Cylinder misfiring
    HO2S wiring concerns (shorted or chafed, bent pins, etc.)
    Damaged exhaust system pipe
    Damaged muffler/tailpipe assembly
    Retarded spark timing
    Damaged Catalytic Converter:
    Use of leaded fuel
    Oil contamination/consumption
    Silicone contamination (sealants/cleaners)

    P0430 - Catalyst System Efficiency Below Threshold (Bank 2) Same as DTC P0420, but opposite bank. See Possible Causes for DTC P0420
    Good Luck Dan

    96 SE 2.5 V-6 manual tranny
    89 Silverado 4 x 4 with snow plow no rust

    Comment


    • #3
      I dont assume that the Engine Coolant Temp Sensor is the one at the bottom of the plastic coolant tank, is it?

      When I painted the coolant tank, the connector for that sensor doesn't want to seat properly and it continually triggers a dummy light on the dash. I assumed this was a low coolant warning, but perhaps I am wrong.
      1998.0 Mercury Mystique 2.5L || De-knauberized ||.................................................. . CHECK
      The token, non-licensed non-DUI member................................................... .....................ENGINE

      Comment


      • #4
        Originally posted by imstock View Post
        I dont assume that the Engine Coolant Temp Sensor is the one at the bottom of the plastic coolant tank, is it?

        When I painted the coolant tank, the connector for that sensor doesn't want to seat properly and it continually triggers a dummy light on the dash. I assumed this was a low coolant warning, but perhaps I am wrong.
        No, that is the low coolant sensor. The ECT is on the driver side of the engine block and can be seen when standing from the driver side.

        Page 2 of 6, Chongo, scroll down to the picture below the "DPFE and TPS"
        http://www.cardomain.com/ride/500739/2
        Last edited by Tony2005; 05-15-2010, 01:39 PM.

        Comment


        • #5
          Well that looks easy to replace... </sarcasm> lol

          Is there a way to test the range using a volt meter, or another way to test the sensor before replacing it?
          1998.0 Mercury Mystique 2.5L || De-knauberized ||.................................................. . CHECK
          The token, non-licensed non-DUI member................................................... .....................ENGINE

          Comment


          • #6
            It really is not that hard 10-15 minutes. If you remove some of the coolant prior to starting it does not pour out when you change the sensor. Or you can do a quick swap and then rinse of the leaked coolant. Re top the coolant tank if needed. I opt for the first choice. Not sure if there is a way to test the sensor. If you are at 80k or better on the engine I would just change the sensor. $30-40.00.
            Good Luck Dan

            96 SE 2.5 V-6 manual tranny
            89 Silverado 4 x 4 with snow plow no rust

            Comment


            • #7
              UPDATE: We've been waiting for my wife's next paycheck to replace the ECT, so it has NOT been done yet. The CEL was reset after the scan but turned back on the following day and stayed on for several days. I assumed it was still P0240 so we ignored it. The light stayed off two days ago and but came on after a long day of cruising yesterday.

              With this new info in mind, are we still thinking ECT, or is this indicative of something else? Also, she is averaging 26mpg still.
              1998.0 Mercury Mystique 2.5L || De-knauberized ||.................................................. . CHECK
              The token, non-licensed non-DUI member................................................... .....................ENGINE

              Comment


              • #8
                I'm still not conviced a ECT sensor is going to clear up a pre-cat code.

                fyi, on my 99 the cel would come on and off for a few months for the pre-cat code before it stayed on. has the pcm updated and that took care of the problem.

                this started to happen on my other 99 also, I jsut installed mil-eliminators and then later headers anyway.
                - 12 Focus SE
                - 95 Mystique LS <-sold
                - 99 Contour SE Sport <- traded in 2/13
                - 99 Contour SeVT <- 3L/NPG Turbo
                - 2k Contour SVT - #2137

                Comment


                • #9
                  Originally posted by BrApple View Post
                  ...has the pcm updated and that took care of the problem...
                  When my buddy scanned it in South Fla he cleared the codes, it stayed off for a couple weeks IIRC then came back on. After the parts grabber at DAP scanned it, it didn't come back for a few days but I am not sure if he cleared it or if it just shut off temporarily after he scanned it and it's been off and on since. Typically on unfortunately.

                  Originally posted by BrApple View Post
                  ...this started to happen on my other 99 also, I jsut installed mil-eliminators and then later headers anyway.
                  Well if I install the mil-eliminators won't that bypass the O2's? I have never heard of them before but thats what I have pieced together so far. Can't this create a domino effect if something goes wrong and the car can't compensate for the rich/lean?

                  Thanks for the input, I appreciate it. Still getting my head around the new platform.
                  1998.0 Mercury Mystique 2.5L || De-knauberized ||.................................................. . CHECK
                  The token, non-licensed non-DUI member................................................... .....................ENGINE

                  Comment


                  • #10
                    Originally posted by imstock View Post
                    Well if I install the mil-eliminators won't that bypass the O2's? I have never heard of them before but thats what I have pieced together so far. Can't this create a domino effect if something goes wrong and the car can't compensate for the rich/lean?
                    The mil-eliminators go on the downstream O2 sensors, which mainly just monitor the performance of the pre catalytic converters.
                    2009 Honda...

                    Comment


                    • #11
                      mil-eliminators only prevent the pre-cat codes. you must have working O2 sensors. also the a/f is only determined by the upstream O2 sensors, the ones before the pre-cat.
                      - 12 Focus SE
                      - 95 Mystique LS <-sold
                      - 99 Contour SE Sport <- traded in 2/13
                      - 99 Contour SeVT <- 3L/NPG Turbo
                      - 2k Contour SVT - #2137

                      Comment


                      • #12
                        The Downstream 02 Sensor was replaced on 7/21/2008 along with the Transmission Range Sensor by the previous owner.

                        Could it be an issue?
                        1998.0 Mercury Mystique 2.5L || De-knauberized ||.................................................. . CHECK
                        The token, non-licensed non-DUI member................................................... .....................ENGINE

                        Comment


                        • #13
                          if you are getting a O2 sensor code or any other code with the pre-cats codes then I would say that it could possible be an issue. if you have only pre-cat codes then typically nothing else is causing that code.

                          at random, check that the secondarys are working and all the clips are intact. my 99 had one clip missing and it caused a p0420. the front bank, bank 2 was disconnected and wasn't openning.
                          - 12 Focus SE
                          - 95 Mystique LS <-sold
                          - 99 Contour SE Sport <- traded in 2/13
                          - 99 Contour SeVT <- 3L/NPG Turbo
                          - 2k Contour SVT - #2137

                          Comment


                          • #14
                            Well, it went off again on the 25th, and has been off since then and we have put about 400 highway miles on it since so...

                            Not going to worry about it for now... will eventually throw some MILs on it if it continues to be sporadic.
                            1998.0 Mercury Mystique 2.5L || De-knauberized ||.................................................. . CHECK
                            The token, non-licensed non-DUI member................................................... .....................ENGINE

                            Comment

                            Working...
                            X